opensubtitles.php, line 803 - endless loop

Please leave details of any bugs or errors that you encounter
Forum rules
Before posting a bug report please ensure that your profile signature includes relevant details about your setup. To help solve any issues it is recommended that you attach a logfile with logging level set to 8.

opensubtitles.php, line 803 - endless loop

Postby Utsi » Mon Feb 08, 2010 8:47 pm

Hi,
this new subtitle thing is one of the coolest features I've seen in a while :-)

I do, however, run into a bit of a problem when trying to use it. It seems it starts looping when it runs into some of the files. I've only managed to use the function from a remote computer, because whenever I try locally, I have to kill firefox. And there's no errors in the log, the only thing I see is the repeating line about opensubtitles.php on the screen.

I'm really looking forward to having this! Maybe it's possible to make it accessible from the GUI? Would be sweet if it downloaded the first sub in the chosen language.
Player: Popcornhour A-100
Webserver : Apache v2.0.63
PHP : v5.3.2
MySQL : v5.1.44
Operating system: Mac OS ("Hackingtosh")
System specs: Intel i7 950 CPU, 12GB RAM
Utsi
Member
Member
 
Posts: 221
Joined: Tue Aug 05, 2008 4:26 am
Location: Norway
Country: Norway (no)

Re: opensubtitles.php, line 803 - endless loop

Postby Pernod » Mon Feb 08, 2010 10:11 pm

Any idea which of your files it's having trouble with? What exactly are you seeing on the screen?
Players : Popcorn A-300 | Popcorn A-200 | Popcorn A-100 | Netgear EVA700
Webserver : Simese v2.6.5 | Apache 2.2.21 | PHP v5.2.17 | MySQL v5.1.32
Server : Windows 7 Professional 64bit - Intel i7-4770K @4.2GHz - 16GB RAM - 5TB HDD | Synology DS412+
AV : Pioneer VSX-915 | Samsung LE40C650

Image
User avatar
Pernod
Senior Member
Senior Member
Developer
 
Posts: 4303
Age: 43
Joined: Thu Jan 25, 2007 6:21 am
Location: Croydon, UK
Country: United Kingdom (uk)

Re: opensubtitles.php, line 803 - endless loop

Postby Utsi » Tue Feb 09, 2010 9:54 am

On the screen I first get a couple of good results, then this:
Code: Select all
Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 0 in /var/www/base/opensubtitles.php on line 803

Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 0 in /var/www/base/opensubtitles.php on line 803

Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 0 in /var/www/base/opensubtitles.php on line 803

Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 0 in /var/www/base/opensubtitles.php on line 803

Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 0 in /var/www/base/opensubtitles.php on line 803

Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 0 in /var/www/base/opensubtitles.php on line 803

Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 0 in /var/www/base/opensubtitles.php on line 803

Warning: unpack() [function.unpack]: Type v: not enough input, need 2, have 0 in /var/www/base/opensubtitles.php on line 803

(over and over again).

I know which disk I have the problem files, but I will have to do a binary search to find out more.
Player: Popcornhour A-100
Webserver : Apache v2.0.63
PHP : v5.3.2
MySQL : v5.1.44
Operating system: Mac OS ("Hackingtosh")
System specs: Intel i7 950 CPU, 12GB RAM
Utsi
Member
Member
 
Posts: 221
Joined: Tue Aug 05, 2008 4:26 am
Location: Norway
Country: Norway (no)

Re: opensubtitles.php, line 803 - endless loop

Postby Utsi » Tue Feb 09, 2010 1:05 pm

Good news - this was a user fault, my fault!

Upon testing the smartsearch parser I had created a couple of dummy .mkv files to test difficult titles. Those were actually empty files with mkv extensions, hence the application failed when trying to process them.
Player: Popcornhour A-100
Webserver : Apache v2.0.63
PHP : v5.3.2
MySQL : v5.1.44
Operating system: Mac OS ("Hackingtosh")
System specs: Intel i7 950 CPU, 12GB RAM
Utsi
Member
Member
 
Posts: 221
Joined: Tue Aug 05, 2008 4:26 am
Location: Norway
Country: Norway (no)

Re: opensubtitles.php, line 803 - endless loop

Postby Pernod » Tue Feb 09, 2010 1:45 pm

Ok, good to know it's working for you. Ideally it should simply skip zero sized files though, I'll try to fix this.
Players : Popcorn A-300 | Popcorn A-200 | Popcorn A-100 | Netgear EVA700
Webserver : Simese v2.6.5 | Apache 2.2.21 | PHP v5.2.17 | MySQL v5.1.32
Server : Windows 7 Professional 64bit - Intel i7-4770K @4.2GHz - 16GB RAM - 5TB HDD | Synology DS412+
AV : Pioneer VSX-915 | Samsung LE40C650

Image
User avatar
Pernod
Senior Member
Senior Member
Developer
 
Posts: 4303
Age: 43
Joined: Thu Jan 25, 2007 6:21 am
Location: Croydon, UK
Country: United Kingdom (uk)


Return to Bugs Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron